Results 1 to 8 of 8

Thread: J type overdrive problems

  1. #1
    SOC Member
    Join Date
    Mar 2016
    Location
    Glasgow
    Posts
    6

    J type overdrive problems

    OK any help would be appreciated. Got stag on the road a year ago after complete restoration. O/d did not work. Stripped and cleaned valve block and worked ok. Got 80 miles out of the engine and the front jackshaft bearing ran and starved o/s head of oil. Engine out and a year later have just got it all running again and guess what,o/d not working. Repeated cleaning of valve block to no avail. Checked solenoid, ok drawing 2 amps and tested on bench. Checked pressure, 20psi residual with o/d disengaged but just the same when engaged, should be 450 psi. No nasty noises, any suggestions before I blow it up or alternatively rip the gearbox out, oh joy!!

  2. #2
    My car now in Florida outside my watering hole....
    Join Date
    May 2013
    Location
    Cambridge
    Posts
    1,251
    Electrics ??

  3. #3
    SOC Member
    Join Date
    Mar 2016
    Location
    Glasgow
    Posts
    6

    Overdrive

    Quote Originally Posted by malc4d View Post
    Electrics ??
    Have checked all electric, fitted new spade to feed and new earth from solenoid. Had solenoid in my hand and connected to check operation, all ok.

  4. #4
    stag8manod
    Join Date
    May 2009
    Location
    Morrinsville, , New Zealand
    Posts
    738
    Hi Stagbarber, Have you checked and cleaned the high pressure filter. It's behind one of the screwed plugs and requires a pin wrench to undo it.
    Cheers Ian A

  5. #5
    International Members down_the_plug_hole's Avatar
    Join Date
    Jan 2017
    Location
    Estonia sometimes, Russia sometimes, China occasionally, with lots of badly planned stops between.
    Posts
    445
    Quote Originally Posted by Stagbarber View Post
    OK any help would be appreciated. Checked solenoid, ok drawing 2 amps and tested on bench. Checked pressure, 20psi residual with o/d disengaged but just the same when engaged, should be 450 psi.
    Change solenoid. First give it a good clean....when removed from the car.
    They always draw steady current.

    Solenoids DO fail.
    They are only a hydraulic valve.

  6. #6
    SOC Member
    Join Date
    May 2014
    Location
    Aylesbury
    Posts
    564
    I had the same issue with a J type nearly 20 years ago. The solenoid 'O' rings had a tiny almost invisible tear in each. Replaced these and cured the fault.

  7. #7
    SOC Member
    Join Date
    Mar 2016
    Location
    Glasgow
    Posts
    6
    Thanks for all your help guys. Bit the bullet and pulled the box yesterday and got another o/d unit that I tested on a g/box. Swapped to my own box and tested by running box up with a huge power drill and activated solenoid, all good. About to put box back in and noticed clutch fork has crack in it and is loose, oh happy stag owning days!!!!

  8. #8
    SOC Member
    Join Date
    Mar 2016
    Location
    Glasgow
    Posts
    6

    Overdrive

    Quote Originally Posted by Stagbarber View Post
    Thanks for all your help guys. Bit the bullet and pulled the box yesterday and got another o/d unit that I tested on a g/box. Swapped to my own box and tested by running box up with a huge power drill and activated solenoid, all good. About to put box back in and noticed clutch fork has crack in it and is loose, oh happy stag owning days!!!!
    Hi all, had a frustrating yet fruitful day. Had to cut the fork off with a fine disc as the bolt was sheared and top part stuck in fork and shaft so save the cross shaft. Then had to cut the cross shaft on another box as it was seized to the fork. Even a bit of heat wouldn't budge it. Got it off in the vice, gentle persuasion with 2 pounder. So with all the bits available box is now refitted and guess what we have overdrive whey hey!!!!. So thanks all for advice and comments.Will strip original overdrive when I get chance to see what's up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •