Announcement

Collapse
No announcement yet.

My 1973 Carmine MOD

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    My 1973 Carmine MOD

    This was my Stag as purchased in the summer of 2012. The only time I have had the hardtop on was then, top has been stored in the back of the garage ever since!


    Still, nice with a hardtop on I think













    Cheers
    Keith
    Attached Files

    #2
    Very smart. I sold on my Carmine hard top and kept the one I restored for my previous (white) Stag, which was painted black.

    22527C1B-B74C-4649-ABDA-1DABD7234C8B.jpg
    Dave
    1974 Mk2, Carmine, ZF 4HP22 Auto, 3.45 Diff, Datsun Driveshafts.

    Comment


      #3
      Then after a few days, the wiring loom burnt out big style under the dash, so I ended up making and fitting a new one..........





      Attached Files
      Last edited by 72BLUE; 13th October 2017, 14:16.

      Comment


        #4
        What a nightmare!

        Comment


          #5
          I hope I never have that problem!

          Carmine is definitely THE colour to have - good choice
          Mike

          Comment


            #6
            Originally posted by mike@thenook View Post
            ......I hope I never have that problem!.........
            My original 40 year old loom was in a poor state, and pretty much the same as a spare one that I also had. The wiring under the bonnet was very brittle and had lots of verdigris. The under-bonnet heat, water, salt etc does it no favours over time. The connector blocks are not moisture proof like on a modern car so the verdigris seems to start there and spread down the length of the cable, turning the copper strands into a hard black wire that gives a higher resistance.

            If anyone has never done so, it might be worth checking out any connector blocks for verdigris and seeing how flexible your wiring is by comparing to known good wiring.

            If I bought another Stag, due to the experience of mine almost catching fire, the first thing I would do is to stick a new loom in it!

            Pic below is what some of my connector blocks were like:





            Cheers
            Keith
            Attached Files
            Last edited by 72BLUE; 14th October 2017, 10:51.

            Comment


              #7
              "Pic below is what some of my connector blocks were like:"

              Pic seems to be missing - you tease!

              Comment


                #8
                Originally posted by StagJonno View Post
                "Pic below is what some of my connector blocks were like:"

                Pic seems to be missing - you tease!
                Whoops! Now fixed I hope!

                Keith

                Comment


                  #9
                  Originally posted by 72BLUE View Post
                  Whoops! Now fixed I hope!

                  Keith
                  Yes - thanks.

                  Comment

                  Working...
                  X